时间:2016-02-26 22:12 来源: 我爱IT技术网 作者:佚名
欢迎您访问我爱IT技术网,今天小编为你分享的电脑教程是服务器系列之:【“SQL2000数据库”运行在普通用户下所需的权限】,下面是详细的分享!
“/”应用程序中的服务器错误和Server Error in ''/'' Application.的终极解决方法
因此,从安全的角度考虑,我们要求所有用户将“SQL2000数据库”安装在独立的分区里面,而且,“SQL2000数据库”必须运行在“普通用户”的状态下。所谓“普通用户”就是指没有任何权限的用户。为什么要将“SQL2000数据库”必须运行在“普通用户”的状态下呢?因为如果使用了“超级管理员”或者“本地系统用户”来运行“SQL2000数据库”,就会造成服务器被入侵。因此,为了您的服务器安全,您务必将“SQL2000数据库”运行在“普通用户”的状态下。同时,要对硬盘的权限做好对应的权限设置“SQL2000数据库”才能正常运行。对于硬盘的权限设置请参考如下:
(假设您的数据安装在E:\Program Files\Microsoft SQL Server\)
1. E盘的根目录(E:\)需要以下权限:
“administrators ”的全部权限
“System ”的全部权限
“SQL2000的运行用户(只应用在当前文件夹)列出文件夹/读数据”的权限
“读属性”的权限
“读扩展属性”的权限
“读取”的权限
2. 数据库的安装目录(E:\Program Files\Microsoft SQL Server\)需要以
下权限:
“administrators ”的全部权限
“System ”的全部权限
“SQL2000的运行用户 ”的全部权限
(假设您的数据备份目录安装在F:\SQLBACK)
1. F盘的根目录(F:\)需要以下权限:
“administrators ”的全部权限
“System ”的全部权限
“SQL2000的运行用户(只应用在当前文件夹)列出文件夹/读数据”的权限
“读属性”的权限
“读扩展属性”的权限
“读取”的权限
2. 数据库的安装目录(F:\SQLBACK)需要以下权限:
“administrators ”的全部权限
“System ”的全部权限
“SQL2000的运行用户 ”的全部权限
特别提醒:无论是安装在E盘还是安装在F盘根目录下的权限,都必须的按照以上的操作来设置,否则都会导致数据库启动失败。很多用户往往是忽
视了“根目录权限”的设置,在设置完“SQL2000的运行用户”以后,就发现再也启动不了SQL2000的数据库。如果您已经发生这种情
况,请您按照以上的说明,重新设置好“根目录的权限”,SQL2000的数据库就可以正常启动。
补充说明:这儿说的“SQL2000的运行用户”,就是在SQL 2000企业管理器----属性中的安全中设置的用户(默认是System用户)。如果您看过了
“星外安全包视频说明”,应该在已将“默认的System用户”改成别的“没有任何权限”的用户,这个“没有任何权限”的用户就是这儿
说的“SQL2000的运行用户”。
SQL2005的运行用户在开始--Microsoft SQL Server 2005--配置工具--SQL Server Configuration Manager,选QL Server 2005服务中,
选“SQL Server(MSSQLSERVER)”属性中设置本帐户。
以上就是关于“SQL2000数据库”运行在普通用户下所需的权限的服务器维护教程分享,更多电脑教程请移步到>>电脑教程频道。
- 评论列表(网友评论仅供网友表达个人看法,并不表明本站同意其观点或证实其描述)
-
